Collaborate Launcher Available

You may have heard about or experienced Problems Joining Collaborate Sessions on Mac OS X 10.8.4 back in June. Blackboard released the Collaborate Launcher on August 17, 2013 to fix these issues and is now available at UCSF. Below is a breakdown of the important information related to the release of the Collaborate Launcher:

Who does it affect? Collaborate users joining from an Apple computer running Mac OS X 10.8.4 or newer PC and Mac OS X 10.8.3 or older users will continue to join sessions as they have in the past.
When will is begin? Saturday, August 17, 2013.
Why do I need to install the Launcher? To fix Java and Mac OS X 10.8.4 related issues. Read more here.
Where do I download the Collaborate Launcher? Just launch any Collaborate session and you will be prompted to download the Launcher if running Mac OS X 10.8.4+.
Do you need admin rights to install the Collaborate Launcher? No, just unzip the downloaded file and you are ready to use Collaborate. Read more here.
What browser should I use? Use either Chrome or Safari to download the launcher and launch Collaborate sessions and recordings. Firefox is currently not supported.

Need more support information? See below:

  1. Step-by-step instructions for downloading and using the Collaborate Launcher
  2. Blackboard Support Article

Please contact LTG staff with any questions about using Collaborate or the new Launcher!

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>